Spectacles - Synchronization issue with system activity data – Incident details

Synchronization issue with system activity data

Resolved
Partial outage
Started 8 months agoLasted 2 days

Affected

App

Partial outage from 1:39 PM to 1:39 PM

Updates
  • Resolved
    Resolved

    We've enabled the Content Management and LookML Management beta apps for all affected users and have completed re-syncing system activity history data.

  • Monitoring
    Monitoring

    We have re-enabled content management and LookML management apps for most users. Some large organizations with extensive Looker history are still syncing. For those organizations, beta access remains disabled.

    If you have any questions or need assistance, please don't hesitate to contact us at support@spectacles.dev. We'll keep you updated and expect to provide the next update by 2024-02-02 20:00 UTC.

  • Identified
    Update

    We are continuing to re-sync system activity data for many of our beta testers, about half of which have completed their sync.

    If you have any questions or need assistance, please don't hesitate to contact us at support@spectacles.dev. We'll keep you updated and expect to provide the next update by 2024-02-02 15:00 UTC.

  • Identified
    Identified

    We've identified an issue with the way Spectacles extracts system activity data from Looker to show query counts (usage) in our new beta features: Content Management and LookML Management.

    A bug introduced on November 19th, 2023 caused Spectacles to report inaccurate usage data for Looker queries created on and after that date.

    We are currently re-syncing historic data from system activity from our beta testers' Looker instances. Both the LookML Management app and the Content Management app will remain disabled while this sync completes. We aim to have these apps restored by the end of the day Friday, February 2nd.

    In cases where we collected accurate history prior to November 19th, 2023, we will manually restore this data to maintain consistency, despite the standard 90-day system activity limit in Looker.

    We are also working on providing details about any content mistakenly deleted during this period due to inaccurate usage numbers. Once we have this information, We commit to restoring any incorrectly deleted content upon request.

    If you have any questions or need assistance, please don't hesitate to contact us at support@spectacles.dev. We'll keep you updated and expect to provide the next update by 2024-02-01 21:00 UTC.

  • Investigating
    Investigating

    We're investigating a synchronization issue between our synced system activity history and your Looker instance. To ensure accuracy and protect your Looker content, we've temporarily disabled the Content Management and LookML Management apps for our beta testers.

    We'll post updates here as we know more.